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1 Introduction

SunGlobe is a tool in SolarSoft (Freeland and Handy, 1998) for selecting pointing using a 3D
representation of the solar globe. It is designed primarily for the Solar Orbiter mission, but can be
used for other missions as well. In the current implementation of the software, images are read in
from the Helioviewer database. As needs arise, other image and data sources can be added in the
future. For example, “hairy ball” magnetic field extrapolations are currently incorporated into the
software.

For the full capabilities of SunGlobe to be realized, it should be used in conjunction with the
SunSPICE package in SolarSoft. This enables the software to read in the ephemeris information
for the spacecraft so that the Sun can be portrayed with the right orientation and perspective. If
the SunSPICE package has not already been installed, instructions for installing it can be found at

https://stereo-ssc.nascom.nasa.gov/sunspice.shtml

SunSPICE will be automatically loaded for instruments which depend on it, such as
STEREO/SECCHI, or it can be listed as one of the “instruments” in the environment variable
SSW_INSTR.

Some features in SunGlobe also depend on the SolarSoft PFSS package. If this package is
installed on the local machine, it will automatically be added to the path. Otherwise, those aspects
of the software that depend on the PFSS package will be unavailable.

2 Starting SunGlobe

The SunGlobe program can be invoked simply by typing sunglobe at the IDL prompt. This will
bring up display window and main controls, as shown in Figure 1. There are also several keywords
which can be passed to the program; the most important of these are explained below.

SPACECRAFT: By default, SunGlobe will be configured for the Solar Orbiter spacecraft. The
spacecraft keyword can be used to select a different spacecraft supported by the SunSPICE
package. For example,

IDL> sunglobe, spacecraft=’ahead’

would configure SunSPICE to instead view the Sun from the viewpoint of the STEREO
Ahead spacecraft. Another alternative is to enter

IDL> sunglobe, spacecraft=’earth’



Figure 1: SunGlobe display window and main controls.
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Figure 2: Controls which determine cursor function.

for observations made from a ground observatory, or near Earth1 orbit (e.g. SDO). There
are also some menu items which will change depending on the value of the SPACECRAFT
keyword.

Note: As of version 17 (03-April-2019), the spacecraft can also be changed from within the
program–see Section 5.4.

TEST OFFSET: Setting the keyword test_offset to an integer value n tells the program to
add n years to the date when accessing the spacecraft ephemeris. For example, if the date is
18-Nov-2016, and the program is called with

IDL> sunglobe, test_offset=5

then the ephemeris data from the same date five years in the future, i.e. 18-Nov-2021, will
be used when calculating the spacecraft position, putting it within the valid range of any
pre-launch sample ephemeris file.

3 Tool layout and main controls

The layout of the SunGlobe program is shown in Figure 1. The widget tool is organized into four
sections. In the center is the image display window, which at the start of the program is blank
except for a heliographic grid. Along the top are pull-down menus which perform various actions.
The main widget controls are arranged in a column along the left side. Along the right side is an
area for the individual images. This starts out blank, and is filled in as images are read in (see
Figure 6).

The cursor can be used interactively within the display window in one of three ways, depending
on which checkbox is selected along the left side. Figure 2 zooms in on the three controls for the
three different cursor functions.

1This special case can be abbreviated to “sunglobe,/earth”.
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Figure 3: SPICE field-of-view overplotted on the solar image.

3.1 Orientation

The program starts with the “Orientation” controls selected. This allows the user to use the
cursor to interactively control the orientation of the three-dimensional solar globe. The observer’s
viewpoint in Carrington heliographic longitude and latitude is displayed, along with the roll angle,
all in degrees. One can also control the orientation by typing into these boxes and pressing the
return key. Another field within this control section displays the solar distance in astronomical
units from which the Sun is observed. Changing this alters the perspective.

3.2 Ephemeris

Selecting the “Ephemeris” checkbox changes the image orientation and observing distance based
on the observation date. This can be overridden by selecting “Lock orientation” in the Orientation
control section. Controls are also provided for changing the observation date and time; when these
are changed, the orientation and distance are updated accordingly, along with applying differential
solar rotation to all images which have been read in.

With “Ephemeris” selected, the cursor controls the spacecraft pointing. The Options pull-down
menu provides the opportunity to overplot the spacecraft boresight or the fields of view of several
of the Solar Orbiter instruments, which can then be controlled by the cursor. Figure 3 shows the
field-of-view of the SPICE instrument overplotted on a zoomed-in section of the Sun.
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Figure 4: Coordinate conversion subwidget.

For spacecraft which provide predictive attitude files (or definitive attitude files for dates in the
past), the “Use ephemeris values” button can be used to select the pointing from the attitude file.

By default, the pointing coordinates displayed in the Ephemeris section are relative to the
roll angle with which the images are displayed. In other words, these pointing values are offsets
from Sun center along the spacecraft y and z axes. The Convert button will convert these into
true helioprojective-cartesian coordinates which are independent of spacecraft roll, as well as into
Carrington longitude and latitude so long as the current pointing is on the disk. The conversion
subwidget is shown in Figure 4. This menu can also be used to modify the pointing in any of
the three displayed coordinate systems. Selecting the “Stay within limb” function will force the
pointing to be on the disk. The Export button produces a JSON file containing all the pointing
information.
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Figure 5: Helioviewer image selection menu.

3.3 Image center

Selecting “Image center” allows the user to interactive move the image left-right and up-down with
the cursor. This is particularly useful when combined with the zoom in and out buttons just below
this section.

4 Reading images

4.1 Helioviewer images

Selecting “Read in Helioviewer image” from the “File” pull-down menu brings up a menu (Figure 5)
for selecting images from the Helioviewer database. First one selects the Helioviewer server, which
can be “GSFC” (Goddard Space Flight Center), “IAS” (Institut d’Astrophysique Spatiale), or
“ROB” (Royal Observatory of Belgium). Each server has it’s own list of observatories which can
then be selected, e.g. “SDO”. Once the observatory has been selected, one can select the associated
instrument, e.g. “AIA”. Finally, one can select the measurement, e.g. “193”. In cases where there’s
only one choice, the program will automatically advance to the next step.

Once the measurement has been selected, the helioviewer database will be searched, and the
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Figure 6: Result of reading in two images.

closest date to the target date will be displayed, along with the difference in days between the two
dates. It’s also possible to change the target date and time for the image selection separately from
the date for the planned observation. One way this can be useful is to read in earlier images to fill
in parts of the Sun which are otherwise not covered. For example, if one read in both a recent AIA
image along with one from two weeks earlier, most of the Sun would be covered.

Figure 6 shows the result of reading in two images, one from SDO/AIA, and the other from
STEREO-A/SECCHI. Once images have been read in, some additional controls become active.
Thumbnails of the read-in images appear along the right side of the tool. Each thumbnail includes
a check box which allows that image to be selected, and controls for the selected image are on the
lower left of the tool. Figure 7 zooms in on these regions. The image control region starts with
text boxes showing the identifier and date/time of the selected image. Below these, the “Move
up/down” buttons can be used to change the order of the images, i.e. which images are overlaid
on which. A slidebar can be used to change the image opacity, or the textbox can be used to enter
in a specific value. Finally, images can be discarded from the tool.

4.2 FITS images

Select “Read in local FITS file” brings up a menu (Figure 8) which allows the user to select and
read in a FITS file locally available on the computer. The “Read file” button brings up a menu to
allow one to explore the directory tree, and select a FITS file to be read. Once the file is read in the
“Adjust color table” button, and the image minimum and maximum fields, can be used to adjust
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Figure 7: Image controls.

how the image will appear in SunGlobe. For full-Sun images, the “Check pointing” button will
display the limb position based on the pointing values in the FITS header. If this is not accurate,
the “Fit limb” button allows one to determine the pointing by selecting a number of points around
the limb.

5 Other capabilities

5.1 PFSS magnetic field model

Selecting “Read in PFSS magnetic field” from the “File” pull-down menu allows one to read in
a Potential Field Source Surface magnetic field extrapolation model consistent with the selected
observation date (Figure 9). Differential rotation is applied in a rather simplistic fashion to this
model to ensure that the field lines match up with the solar features, so if the observation date is
changed considerably, it may be best to reingest the PFSS model. Selecting “PFSS mangetic field
on/off” under the “Options” pull-down menu controls whether or not the model is visible.

Figure 10 shows the controls used to form the magnetic field extrapolation. Two strategies
for populating the field line footpoints on the solar surface are available, either uniform spacing
or weighted by field strength. For uniforming spacing, one can select the approximate spacing in
degrees between field lines, while the target number of lines can be selected in the weighted case.
One can also select an exclusion zone in degrees around the poles. This option can be useful to
prevent most of the lines being allocated to the polar coronal holes when the field strength weighting
option is selected.
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Figure 8: Menu for reading in FITS files.
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Figure 9: Potential Field Source Surface magnetic field extrapolation overplotted on the solar
images.

Figure 10: PFSS extrapolation controls.
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Figure 11: Controls for estimating the magnetic connection point.

5.2 Estimate magnetic connection point

Using the same PFSS magnetic field model, combined with a simple Parker spiral model beyond
the source surface at 2.5 R�, one can estimate the point on the solar surface that is magnetically
connected to the spacecraft. Figure 11 shows the available controls for this action. One can either
choose the connection point for the spacecraft based on the ephemeris, or based on the data in the
orientation box (equivalent to locking the orientation). The next two controls are for the target
number of lines to trace, and the Gaussian width in degrees at the source surface to use in randomly
distributing these lines. This gives an estimate of the uncertainty in the calculation. One can also
control the assumed solar wind speed for the Parker spiral calculation.

The result of the calculation will be a red oval on the solar surface showing the 2σ uncertainty
in the connection point. Usually, only one connection point will be found, but the program also can
suggest multiple connection points. Figure 12 shows a rare case where three possible connection
points were found. The percentage of field lines associated with each error oval is also shown, to
give an indication of the relative importance.

Selecting “Magnetic connection point on/off” under the “Options” pull-down menu controls
whether or not the connection estimation points are visible.

5.3 Read magnetic connection file

A more sophisticated way of estimating the magnetic connection point is to use the Magnetic
Connectivity Tool at http://connect-tool.irap.omp.eu/. The output from this tool can be
downloaded and read in through the “Read magnetic connection file” option. Selecting this option
brings up a widget allowing one to select the file to be read in. The normal file extension for these
files is “.ascii”. Figure 13 shows the result of reading in an ADAPT model for connectivity to
Parker Solar Probe. Oval highlights have been added to make the data more visible. (Rotating
the globe helps to view the data.) The red points show the result of the model for fast solar wind,
while blue marks the same for the slow solar wind. If the output file is based on measured solar
wind values, then the data would be displayed with green points. The intensity of the colors is
related to the probability density.

Selecting “Connection file image on/off” under the “Options” pull-down menu controls whether
or not the connection tool data are visible. Toggling these data off and back on again is another
way to help visualize their locations.
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Figure 12: Estimated magnetic connection points on the solar surface, for a rare case where three
possible connection regions were found. Note that the globe has been rotated to better show these
regions.
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Figure 13: Overlaid output from the Magnetic Connectivity Tool. Two regions of possible connec-
tion are highlighted. Modelled connectivity for the fast solar wind are shown in red, while blue
represents the slow solar wind.
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Figure 14: Menu for changing the view to a different spacecraft or planet.

5.4 Change spacecraft

The “Change spacecraft” option under the “File” pull-down menu brings up a menu (Figure 14)
for changing the viewpoint to be a different spacecraft or planet. There’s also a box for “other”
for selecting other solar system bodies. This option is best used with the numeric IDs for objects
whose SPICE kernels have already been loaded externally to SunGlobe. For example, if the file
“lovejoy.bsp” contained an ephemeris for Comet Lovejoy with a body ID of 1003162, and if this file
was loaded with the command

IDL> cspice_furnsh, ’lovejoy.bsp’

then one could set the comet to be the viewpoint by entering 1003162 into the “Other” field.

5.5 Image save and restore

The options “Save images” and “Restore images” under the “File” pull-down menu allow the current
set of images to be saved into a data file, and then restored. The data are stored in files with the
extension “.geny”, e.g. “sunglobe.geny”. This option is recommended mainly for temporary storage,
since more up-to-date images become available with the passage of time.

5.6 Write JPEG

The “Write JPEG” option under the “File” pull-down menu will save the current image window
into a JPEG file.

5.7 Actions

The “Actions” pull-down menu allows one to reset a number of the tool parameter back to their
initial values, such as image roll angle or zoom factor.
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Figure 15: Left panel shows the painting of the Solar Orbiter SPICE field-of-view on the solar
surface. Right panel shows the same region as seen from Earth.

5.8 Fields-of-view

When the Solar Orbiter spacecraft is set as the viewpoint, the configure pull-down menu allows
one to configure the (sub-disk) fields-of-view of the SPICE, EUI, and PHI instruments. For all
other viewpoints, a generic rectangular field-of-view can be configured instead. The individual
fields-of-view can be turned on or off through the “Options” pull-down menu.

5.8.1 Painting fields-of-view

The “Paint FOV” pull-down menu allows one to paint the currently configured field-of-view of an
instrument onto the solar surface. The purpose of this is to compare what is visible from one point-
of-view with that from another point-of-view. This is demonstrated in Figure 15, which compares
the field-of-view of the SPICE instrument on Solar Orbiter with how the same region of the Sun is
seen from Earth.

Any painted region will persist until it is either erased or replaced by another painted region.
Only one painted region is allowed at any time. Other actions, such as changing the spacecraft
pointing or the solar orientation, will not change the painted region. To change the painted region
to the reflect the current pointing and orientation, simply repeat the paint option.

5.9 Orbit trace

The “Orbit trace on/off’ entry under the “Options” pull-down menu allows one to display a tracing
of the sub-orbital point on the solar surface as a function of time. Timesteps in the past (relative to
the target date) are shown as crosses (×), while those in the future are shown as diamonds (�). Both
symbols on top of each other mark the target time. “Configure orbit trace” under the “Configure”
pull-down menu allows one to define the number of time steps, and difference in time between them.
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Figure 16: Demonstration of calling SunGlobe from another program.

5.10 Active region IDs

The “Active region IDs on/off” entry under the “Options” pull-down menu allows one to display
NOAA active region ID numbers. The NOAA database is searched up to 15 days before the target
time to cover the full Sun.

6 Interacting with another program

It is intended that SunGlobe be capable of interacting with other programs. The routine
sunglobe_demo.pro is a simple demonstration of the present capabilities of SunGlobe in this
regard. Currently, SunGlobe supports receiving date/time values from the calling program, and
sending back the spacecraft pointing values. Other capabilities, such as instrument field-of-view
parameters, are anticipated to be added. Specific information about the events which can be sent to
SunGlobe, and the events which can be sent back from SunGlobe, are described in the information
header of the routine sunglobe_event.pro.

The first step in communicating between SunGlobe and another program is for that program to
call SunGlobe. There are several keywords in this call which make it possible for the two programs
to pass information back and forth:

GROUP LEADER: The widget ID of the group leader calling SunGlobe.

SENDBASE: Returns a widget ID in the SunGlobe program that events can be sent to.

RETURNID: The widget ID in the group leader that SunGlobe can send events to. This should
be the ID of a widget that does not otherwise take events, and whose UVALUE can be
overridden. The routine sunglobe_demo uses one of its widget subbases for this purpose.

In sunglobe_demo.pro this is done through the command

sunglobe, target_date, group_leader=event.top, $

sendbase=sunglobe_base, returnid=sstate.wscpoint, $

test_offset=sstate.test_offset
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The demonstration program sunglobe_demo.pro has controls for the observation date and time.
When these are changed, the new target date/time is sent to SunGlobe via the following code:

send_event = {id: 0L, top: 0L, handler: 0L, target_date: target_date}

widget_control, sstate.sunglobe_base, send_event=send_event, $

set_uvalue=’EVENT_TARGET_DATE’

where sstate.sunglobe_base is the value returned via the SENDBASE keyword in the previous
call to sunglobe.

Correspondingly, the SunGlobe can send pointing values back to the calling routine with the
“Send pointing values” button in the coordinate conversion subwidget (Figure 4) which is called
from the Ephemeris section of the controls on the left side of the tool. This will send an event
to the calling routine with a UVALUE of SUNGLOBE_POINTING, and with the following tags in the
event structure:

XSC: Spacecraft x pointing in arc seconds

YSC: Spacecraft y pointing in arc seconds

ROLL: Spacecraft roll angle in degrees for which the spacecraft pointing values are valid.

XHPC: HPC X pointing in arc seconds

YHPC: HPC Y pointing in arc seconds

ONDISK: Flag if Carrington coordinates are valid.

CRLN: Carrington longitude in degrees

CRLT: Carrington latitude in degrees

TARGET DATE: The target date for which the pointing values are valid. It’s recommended in
this scenario to use the calling program to control the target date, and to pass this on to
SunGlobe, rather than using the internal controls within SunGlobe to change the target date.
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